Wiki

For you to give feedback to the Heartland moderators. Wish lists, fault reports, etc. You may get an answer, you may not. As in all things, it largely depends on how nicely you ask the people in charge... You're welcome.
Post Reply
User avatar
Being645
Above the Chemist
Posts: 12592
Joined: 09 Apr 2009, 12:54
Location: reconstruction status: 76,8%

markfiend wrote:I didn't mean the login to the wiki, but login to the server running the software. They are different (for security reasons)

But thanks. ;D
I see ... :lol: ... anyway, a new password might be good thing ... :wink: ...
User avatar
Being645
Above the Chemist
Posts: 12592
Joined: 09 Apr 2009, 12:54
Location: reconstruction status: 76,8%

Being645 wrote:
Being645 wrote:ALARM!

It looks like something is wrong with the SistersWiki ... :eek: :eek: :eek: ...
AGAIN !!!... :eek: ...
And again ... since yesterday afternoon, already !!! ... :? ...
SistersWiki wrote:Sorry! This site is experiencing technical difficulties.



And back again ... ... ;D ;D ;D ...
User avatar
Being645
Above the Chemist
Posts: 12592
Joined: 09 Apr 2009, 12:54
Location: reconstruction status: 76,8%

ring, ring, ring ... :wink: ...
SistersWiki wrote:Sorry! This site is experiencing technical difficulties.
User avatar
Being645
Above the Chemist
Posts: 12592
Joined: 09 Apr 2009, 12:54
Location: reconstruction status: 76,8%

Hah, back ... ;D ... thanks ... :notworthy: ...
User avatar
Being645
Above the Chemist
Posts: 12592
Joined: 09 Apr 2009, 12:54
Location: reconstruction status: 76,8%

Don't know what happened, but checking my statistical data on page views with today's figures is irritating ...

22/02/15 - Current Events - 341,500 - Main Page - 634,909
27/02/15 - Current Events - 341,081 - Main Page - 633,003

:eek: ... thousands of page views disappeared ... :?: ...

When I'm logged in, things look different again ... :? ...
27/02/15 - Current Events - 343,972 - Main Page - 637,232

crazy times ... :lol: ... maybe it's New York over in the Wiki ... :lol: ...
User avatar
Being645
Above the Chemist
Posts: 12592
Joined: 09 Apr 2009, 12:54
Location: reconstruction status: 76,8%

Encore ...
SistersWiki wrote:Sorry! This site is experiencing technical difficulties.
Maybe it's back by tomorrow, or maybe it's a punishment because I'm such a bad girl ... but ... :( :? :( ... please check anybody.
User avatar
Being645
Above the Chemist
Posts: 12592
Joined: 09 Apr 2009, 12:54
Location: reconstruction status: 76,8%

Being645 wrote:Encore ...
SistersWiki wrote:Sorry! This site is experiencing technical difficulties.
Maybe it's back by tomorrow, or maybe it's a punishment because I'm such a bad girl ... but ... :( :? :( ... please check anybody.

Ah ... it's back to function ... :) ...
User avatar
Quiff Boy
Herr Administrator
Posts: 15915
Joined: 25 Jan 2002, 00:00
Location: Lurking and fixing
Contact:

As well as last night's forum maintenance I also ran a few updates on the wiki - sisterswiki.org

It was quite a substantial update of the underlying wiki software and required a full re-build/re-creation of the site, so there is a teeny, weeny, infinitesimally small chance some things may have been configured differently (by which I mean incorrectly).

Hopefully I haven't broken any of Being645's incredible work ( :!: ) but if you do notice any quirks or issues, pop them on this thread and I'll have a look.

Thanks :notworthy:
If it ain’t broke, fix it until it is broke.
User avatar
Pista
Cureboi
Posts: 14202
Joined: 25 Jun 2006, 15:03
Location: Lost In A Forest
Contact:

Nice work chief :D
:notworthy: :notworthy:
Cheers.
Steve
Just like the old days
TheCureCommunity
User avatar
Being645
Above the Chemist
Posts: 12592
Joined: 09 Apr 2009, 12:54
Location: reconstruction status: 76,8%

Quiff Boy wrote:As well as last night's forum maintenance I also ran a few updates on the wiki - sisterswiki.org

It was quite a substantial update of the underlying wiki software and required a full re-build/re-creation of the site, so there is a teeny, weeny, infinitesimally small chance some things may have been configured differently (by which I mean incorrectly).

Hopefully I haven't broken any of Being645's incredible work ( :!: ) but if you do notice any quirks or issues, pop them on this thread and I'll have a look.

Thanks :notworthy:
Cool ... :D :D :D ... and of course a great job! ... :notworthy: :notworthy: :notworthy: ... Thank you very much!!! ... ;D ;D ;D ...

at first short sight, one unpleasant thing I've noticed is that the fonts have changed ... the headlines look like Times New Roman ...
In addition, the font size of the non-serif main text font is 1 pt or maybe even 2 pt larger than before ... best compared with the captions, as they kept their font size ...

AND ... I have no more access to the Special Pages ... :!: ...
User avatar
Quiff Boy
Herr Administrator
Posts: 15915
Joined: 25 Jan 2002, 00:00
Location: Lurking and fixing
Contact:

Being645 wrote:
Quiff Boy wrote:As well as last night's forum maintenance I also ran a few updates on the wiki - sisterswiki.org

It was quite a substantial update of the underlying wiki software and required a full re-build/re-creation of the site, so there is a teeny, weeny, infinitesimally small chance some things may have been configured differently (by which I mean incorrectly).

Hopefully I haven't broken any of Being645's incredible work ( :!: ) but if you do notice any quirks or issues, pop them on this thread and I'll have a look.

Thanks :notworthy:
Cool ... :D :D :D ... and of course a great job! ... :notworthy: :notworthy: :notworthy: ... Thank you very much!!! ... ;D ;D ;D ...

at first short sight, one unpleasant thing I've noticed is that the fonts have changed ... the headlines look like Times New Roman ...
In addition, the font size of the non-serif main text font is 1 pt or maybe even 2 pt larger than before ... best compared with the captions, as they kept their font size ...

AND ... I have no more access to the Special Pages ... :!: ...
You should now have access to special pages :)

Also, I've had to reverse outage https stuff and move it back to standard http as it was breaking the youtube video embeds :( I'll look at how to get the video embeds working as https as that would be much better in the long run.

Also i'll look at the font changes - possible a change to the template introduced with a later version of the wiki software that we will need to manually override.
If it ain’t broke, fix it until it is broke.
User avatar
Quiff Boy
Herr Administrator
Posts: 15915
Joined: 25 Jan 2002, 00:00
Location: Lurking and fixing
Contact:

In the meantime, I've made it so that the wiki can be accessed via

http://sisterswiki.org

and

https://sisterswiki.org

All the YouTube video embeds are currently calling a http version of the youtube url, so don't work if our wiki pages is https. It's causing a "mixed mode" security error as some of the content on the page is secure and some isn't, and browsers don't like that.

Basically, you need the wiki and the youtube to be both using or http, or both using https, but not a mix of both.

However, if you look at the docs for the EmbedVideo extension it does look as if there's something you can do reference youtube vids using https:

https://www.mediawiki.org/wiki/Extension:EmbedVideo

You could maybe try editing one https version of a page that has some videos in and playing around with the format of the embed codes to see if that works?

Worst case scenario is that it's a setting you have to do for EVERY video on EVERY page, in which case it's probably easiest to just not bother using the https secure version of the wiki address at all, and sticking with the standard one.

See how you get on and let me know :)
If it ain’t broke, fix it until it is broke.
User avatar
Being645
Above the Chemist
Posts: 12592
Joined: 09 Apr 2009, 12:54
Location: reconstruction status: 76,8%

Quiff Boy wrote: You should now have access to special pages :)

Also, I've had to reverse outage https stuff and move it back to standard http as it was breaking the youtube video embeds :( I'll look at how to get the video embeds working as https as that would be much better in the long run.

Also i'll look at the font changes - possible a change to the template introduced with a later version of the wiki software that we will need to manually override.
Access to special pages works, not so "Confirm Account Request"
[2d6d8fa5ce51a95bec68616b] 2017-04-11 21:53:21: Fatal exception of type "Error"
Apart from the fonts, the thumbnail frames around pictures (and videos) are thinner left and right hand, so the space for captions is less wide and
plenty captions need (and take) an additional line now ... for example right in the first picture on the Main Page ...
https://sisterswiki.org/Main_Page

The most important thing atm is the fonts, however. Once these are back to what they were, other changes should become way easier to detect ... :wink: ...
Quiff Boy wrote:In the meantime, I've made it so that the wiki can be accessed via

http://sisterswiki.org and https://sisterswiki.org

[...]
https://www.mediawiki.org/wiki/Extension:EmbedVideo

You could maybe try editing one https version of a page that has some videos in and playing around with the format of the embed codes to see if that works?

Worst case scenario is that it's a setting you have to do for EVERY video on EVERY page, in which case it's probably easiest to just not bother using the https secure version of the wiki address at all, and sticking with the standard one.

See how you get on and let me know :)
OK. I understand. So, if possible, you want to switch off the http-version as soon as the https-version works?

I check out the instructions given under the extension tomorrow ... as of now, there are "only" 192 videos embedded, so if the problem can be solved by adding whatever formular to each of them, then it's work, but doable within reasonable time ... on the other hand, I would definitely prefer to integrate videos directly into the SistersWiki, without embedding them from any external source ... but, of course, this would take a lot of space (and more linking to original sources) ... if it is possible at all? Gotta think this over ... :wink: ... at least (or at least it seems to me that), the above problems were resolved in one go ... :lol: ...

More tomorrow ... :D ...
User avatar
Being645
Above the Chemist
Posts: 12592
Joined: 09 Apr 2009, 12:54
Location: reconstruction status: 76,8%

Ha! You've already resolved the https/http issue with the videos already ... ;D ... Bravo ... :notworthy: :notworthy: :notworthy: ...
User avatar
Being645
Above the Chemist
Posts: 12592
Joined: 09 Apr 2009, 12:54
Location: reconstruction status: 76,8%

Oh! The page views counting is gone ... the horror ... :lol: ...

as that's the only feedback I sometimes get for weeks or months on length ...
User avatar
Being645
Above the Chemist
Posts: 12592
Joined: 09 Apr 2009, 12:54
Location: reconstruction status: 76,8%

User avatar
Quiff Boy
Herr Administrator
Posts: 15915
Joined: 25 Jan 2002, 00:00
Location: Lurking and fixing
Contact:

Damn :(

You'd expect someone else to build a separate 3rd-party replacement for this.
If it ain’t broke, fix it until it is broke.
User avatar
Quiff Boy
Herr Administrator
Posts: 15915
Joined: 25 Jan 2002, 00:00
Location: Lurking and fixing
Contact:

Being645 wrote:Ha! You've already resolved the https/http issue with the videos already ... ;D ... Bravo ... :notworthy: :notworthy: :notworthy: ...
All I did was remove the force-https function so you could still browse the site on http.

I didn't do anything to actually investigate fixing the https video embed issue. Are you seeing a change in behaviour? Or do you mean videos now work when browsing using http?
If it ain’t broke, fix it until it is broke.
User avatar
Quiff Boy
Herr Administrator
Posts: 15915
Joined: 25 Jan 2002, 00:00
Location: Lurking and fixing
Contact:

I'll look into font size.

I suspect the base font size has been increased in later version of media wiki to aid readability.

Generally speaking, forcing font sizes like you've done for headings etc is a bad idea. A better technique is to specify heading levels using html tags such as H1, H2, H3 and then define the size of each heading level as a % of the base font size.

Bit that's by the bye. I'll see if there's a neat way of restoring the smaller font size - hopefully it will be a simple css change.
If it ain’t broke, fix it until it is broke.
User avatar
Quiff Boy
Herr Administrator
Posts: 15915
Joined: 25 Jan 2002, 00:00
Location: Lurking and fixing
Contact:

So, one way or another, that covers:

- https videos
- fonts
- stats

Is there anything else I need to look at? Are we just missing Confirm Account Request then?
If it ain’t broke, fix it until it is broke.
User avatar
Quiff Boy
Herr Administrator
Posts: 15915
Joined: 25 Jan 2002, 00:00
Location: Lurking and fixing
Contact:

I've updated the EmbedVideo and ConfirmAccount plugins to their latest versions.

(see the /Special:Version wiki page for details)

Give them a try now and see if that's fixed anything.
If it ain’t broke, fix it until it is broke.
User avatar
Being645
Above the Chemist
Posts: 12592
Joined: 09 Apr 2009, 12:54
Location: reconstruction status: 76,8%

Quiff Boy wrote:I've updated the EmbedVideo and ConfirmAccount plugins to their latest versions.

(see the /Special:Version wiki page for details)

Give them a try now and see if that's fixed anything.
ConfirmAccount looks normal now... :D :notworthy: :notworthy: ...

and the videos are visible ... :D ...
BUT no longer in thumb containers, therefore without any distance to the text.
Also they come in a wide rectangle autoformat ... example: https://sisterswiki.org/Sun,_20-Nov-2016


IMHO, adjusting the fonts/font sizes is most important. Times New Roman headlines look so funny when the rest of the text is non-serif...

The forced headings seemed the only way to me to avoid them appearing in the tocs or creating autotocs while I wanted to have larger subheads nonetheless ...
but I will of course check out your suggestions ... btw, I said before that the font size of captions did not change ... that was wrong. They are also larger.

Without page views, it's all very frustrating... :( ... you do something and see absolutely no effect and no feedback
except for what you're talking with yourself, unless you regularly run over the market shouting "See what I've done!!!" ... :urff: ...
Last edited by Being645 on 13 Apr 2017, 15:52, edited 1 time in total.
User avatar
Quiff Boy
Herr Administrator
Posts: 15915
Joined: 25 Jan 2002, 00:00
Location: Lurking and fixing
Contact:

- ConfirmAccount: cool 8)

- Videos: damn.

I've put the force-https back in as that doesn't seem to break the videos playing. I suspect the plugin has changed the way the videos are embedded and that's clashing with how you;veprevioulsy been inserting them.

Could you try editing one of the pages and re-embedding them?

- Font - I'll look at that next. Personally I think that's less important than getting the thing working as you can still read stuff, even if the headings look a little wonky, but most issues seem to be resolved now, so fonts will be next :)

- Stats: that's a pain. Let me know if you find an alternative plugin. Otherwise, the wiki does have google analytics installed so if you want to know what people are looking at I could always give you access to that?
If it ain’t broke, fix it until it is broke.
User avatar
Being645
Above the Chemist
Posts: 12592
Joined: 09 Apr 2009, 12:54
Location: reconstruction status: 76,8%

<Could you try editing one of the pages and re-embedding them?>

OK, I'll try out the instructions given under
https://www.mediawiki.org/wiki/Extension:EmbedVideo again.
Didn't work before but might work with the updated extension.

But not now. I gotta leave in a minute and be back only in the evening ...


< - Stats: that's a pain. Let me know if you find an alternative plugin.
Otherwise, the wiki does have google analytics installed so if you want to know
what people are looking at I could always give you access to that? >

That's at least something. Not really the same, though, because it's not visible to everyone ...
but I guess it would it enable me to go on with my pretty list, at least? ...
https://sisterswiki.org/Talk:Current_events
User avatar
Quiff Boy
Herr Administrator
Posts: 15915
Joined: 25 Jan 2002, 00:00
Location: Lurking and fixing
Contact:

Being645 wrote:<Could you try editing one of the pages and re-embedding them?>

OK, I'll try out the instructions given under
https://www.mediawiki.org/wiki/Extension:EmbedVideo again.
Didn't work before but might work with the updated extension.

But not now. I gotta leave in a minute and be back only in the evening ...


< - Stats: that's a pain. Let me know if you find an alternative plugin.
Otherwise, the wiki does have google analytics installed so if you want to know
what people are looking at I could always give you access to that? >

That's at least something. Not really the same, though, because it's not visible to everyone ...
but I guess it would it enable me to go on with my pretty list, at least? ...
https://sisterswiki.org/Talk:Current_events
I'll need an email address that's registered with google to add you. Your usual .de address doesn't seem to work.
If it ain’t broke, fix it until it is broke.
Post Reply